pod updateをかけてみたところ、CocoaPods 1.0.0の案内が出るので CocoaPodsをアップデートしてみた。

pod update
$ pod update CocoaPods 1.0.0 is available. To update use: `gem install cocoapods` Until we reach version 1.0 the features of CocoaPods can and will change. We strongly recommend that you use the latest version at all times.

CocoaPodsを1.0.0にアップデート。

gem install cocoapods
sudo gem install cocoapods

すると、pod updateすると、エラーが発生する。

pod update
$ pod update Update all pods Re-creating CocoaPods due to major version update. Updating local specs repositories Analyzing dependencies [!] The dependency `Google/Analytics` is not used in any concrete target. The dependency `GoogleIDFASupport` is not used in any concrete target. The dependency `XCGLogger (~> 3.3)` is not used in any concrete target.

どうやら、Podfileの変更が必要なようだ。CocoaPods 1.0.0 からtarget~endで括る必要があるようだ。この記述で正常に動作した。

Podfile
#source 'https://github.com/CocoaPods/Specs.git' platform :ios, '8.0' use_frameworks! #target~endで括る必要がある。 target "Projectname" do pod 'Google/Analytics' pod 'GoogleIDFASupport' pod 'XCGLogger', '~> 3.3' end

参考:

You have to specify a target for each pod.

Podfile Syntax Reference